We have confirmed that there are currently no issues affecting the below venues as they are closed for holiday on the previously mentioned date.
Aequitas NEO Exchange: NEO-L [NEOE] - 2025-10-13
Aequitas NEO Exchange: NEO-N [NEON] - 2025-10-13
This alert will now be closed.
We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.
Yours sincerely, BMLL Support Team
Posted Oct 14, 2025 - 11:13 UTC
Identified
Data for the following exchanges and their associated Market Identifier Codes (MICs) is delayed as a result of delayed file generation by our supplier:
Aequitas NEO Exchange: NEO-L [NEOE] - 2025-10-13
Aequitas NEO Exchange: NEO-N [NEON] - 2025-10-13
Our engineers are working with the supplier to accelerate delivery and processing will begin as soon as the data is available. We will provide regular updates on the progress through the BMLL Status Page.
We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.
Yours sincerely, BMLL Support Team
Posted Oct 14, 2025 - 10:22 UTC
This incident affected: Data - Equities & ETFs - Americas (Aequitas NEO Exchange: NEO-L [NEOE], Aequitas NEO Exchange: NEO-N [NEON]).