We are pleased to inform you that we have successfully resolved the issue of incorrect data for the following exchanges and their associated Market Identifier Codes (MICs):
SIP [@SIP] - 2026-02-23
NYSE: American [XASE] - 2026-02-23
NYSE: Arca [ARCX] - 2026-02-23
NYSE: Texas [XCHI] - 2026-02-23
NYSE: Main [XNYS] - 2026-02-23
NYSE: National [XCIS] - 2026-02-23
Our engineering team has confirmed that the data for the exchanges above is accurate and reflects the latest available information.
We understand the importance of accurate data for your operations and apologise for any inconvenience. For further questions and support, don't hesitate to contact the BMLL support team at support@bmlltech.com.
Your sincerely,
BMLL Support Team
Posted Feb 24, 2026 - 17:23 UTC
Investigating
We are currently investigating an issue where users may be encountering incorrect data for the following exchanges and their associated Market Identifier Codes (MICs):
SIP [@SIP] - 2026-02-23
NYSE: American [XASE] - 2026-02-23
NYSE: Arca [ARCX] - 2026-02-23
NYSE: Texas [XCHI] - 2026-02-23
NYSE: Main [XNYS] - 2026-02-23
NYSE: National [XCIS] - 2026-02-23
Our engineering team is actively investigating the root cause of the problem to ensure a swift resolution. We will provide regular updates on the investigation progress through the BMLL Status Page.
We understand the importance of accurate data for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.
Yours sincerely,
BMLL Support Team
Posted Feb 24, 2026 - 11:32 UTC
This incident affected: Data - Equities & ETFs - Americas (NYSE: American [XASE], NYSE: Arca [ARCX], NYSE: Texas [XCHI], NYSE: Main [XNYS], NYSE: National [XCIS], SIP [@SIP]).