Data Incomplete - BME - 2026-06-04

Incident Report for BMLL Status Dashboard

Resolved

Data for the following exchanges and their associated Market Identifier Codes (MICs) is incomplete as a result of packet loss impacting raw data:

BME [XMAD]

Regrettably, we have been advised that the missing data is irretrievable.

Packet loss on the real-time capture resulted in dropped order-delete/modify messages, leaving phantom price levels in the order books. Order-book data is affected for 28 tickers intermittently, starting with 10:11 UTC to close.

Our engineers continue to investigate potential avenues of improving order book quality by removing the artefacts caused by the packet loss.

Trades, auction and quote-enriched trade analytics data is not impacted.

This alert will now be closed.

We understand the importance of accurate data for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Jun 16, 2026 - 08:29 UTC

Identified

Data for the following exchanges and their associated Market Identifier Codes (MICs) is incomplete as a result of packet loss impacting raw data:

BME [XMAD]

Our engineers are working with the supplier to accelerate delivery and processing will begin as soon as the data is available. We will provide regular updates on the progress through the BMLL Status Page.

We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Jun 05, 2026 - 13:41 UTC
This incident affected: Data - Equities & ETFs - EMEA (BME [XMAD]).