Ongoing Incomplete Data - Members Exchange and MIAX

Incident Report for BMLL Status Dashboard

Monitoring

We are continuing to track an issue causing intermittent packet loss in the raw data files delivered by our upstream data provider. This packet loss is resulting in data quality degradation for the following exchanges and their associated Market Identifier Codes (MICs):

Members Exchange [MEMX]

MIAX Pearl Equities [EPRL]

Our upstream supplier has implemented a fix to address the recurring packet loss, and early indicators show improvement.

Our engineering team continues to monitor the daily data feeds closely while concurrently investigating alternative avenues to recover and backfill the missing data for all impacted dates.

The impacted dates/MICs include:

2026-05-28 - EPRL
2026-06-01 - EPRL
2026-06-02 - EPRL and MEMX
2026-06-03 - EPRL
2026-06-04 - EPRL and MEMX
2026-06-05 - EPRL
2026-06-09 - EPRL and MEMX

We understand the importance of accurate data for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Jun 11, 2026 - 12:47 UTC

Update

We are continuing to track an issue causing intermittent packet loss in the raw data files delivered by our upstream data provider. This packet loss is resulting in data quality degradation for the following exchanges and their associated Market Identifier Codes (MICs):

Members Exchange [MEMX]

MIAX Pearl Equities [EPRL]

Our supplier is actively working on a fix, but we expect this instability to persist into next week until their scheduled remediation work is complete.

Our engineering team is concurrently investigating alternative avenues to recover and backfill the missing data for all impacted dates.

The impacted dates/MICs include:

2026-05-28 - EPRL
2026-06-01 - EPRL
2026-06-02 - EPRL and MEMX
2026-06-03 - EPRL
2026-06-04 - EPRL and MEMX
2026-06-05 - EPRL
2026-06-09 - EPRL and MEMX

We understand the importance of accurate data for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Jun 10, 2026 - 07:42 UTC

Update

We are continuing to track an issue causing intermittent packet loss in the raw data files delivered by our upstream data provider. This packet loss is resulting in data quality degradation for the following exchanges and their associated Market Identifier Codes (MICs):

Members Exchange [MEMX]

MIAX Pearl Equities [EPRL]

Our supplier is actively working on a fix, but we expect this instability to persist into next week until their scheduled remediation work is complete.

Our engineering team is concurrently investigating alternative avenues to recover and backfill the missing data for all impacted dates.

The impacted dates/MICs include:

2026-05-28 - EPRL
2026-06-01 - EPRL
2026-06-02 - EPRL and MEMX
2026-06-03 - EPRL
2026-06-04 - EPRL and MEMX
2026-06-05 - EPRL

We understand the importance of accurate data for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Jun 06, 2026 - 08:00 UTC

Identified

We are continuing to track an issue causing intermittent packet loss in the raw data files delivered by our upstream data provider. This packet loss is resulting in data quality degradation for the following exchanges and their associated Market Identifier Codes (MICs):

Members Exchange [MEMX]

MIAX Pearl Equities [EPRL]

Our supplier is actively working on a fix, but we expect this instability to persist into next week until their scheduled remediation work is complete.

Our engineering team is concurrently investigating alternative avenues to recover and backfill the missing data for all impacted dates.

The impacted dates/MICs include:

2026-05-28 - EPRL
2026-06-01 - EPRL
2026-06-02 - EPRL and MEMX
2026-06-03 - EPRL
2026-06-04 - EPRL and MEMX

We understand the importance of accurate data for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.

Yours sincerely,
BMLL Support Team
Posted Jun 05, 2026 - 17:02 UTC
This incident affects: Data - Equities & ETFs - Americas (Members Exchange [MEMX], MIAX Pearl Equities [EPRL]).