We have identified and implemented a fix to resolve the issue causing incomplete metrics data since 2026-08-12 for the following exchanges and their associated Market Identifier Codes (MICs):
BME [XMAD]
Borsa Italiana [XMIL]
Euronext: Amsterdam [XAMS]
Euronext: Brussels [XBRU]
Euronext: Dublin [XDUB]
Euronext: Lisbon [XLIS]
Euronext: Oslo [XOSL]
Euronext: Paris [XPAR]
London Stock Exchange [XLON]
Nasdaq Nordic: Copenhagen [XCSE]
Nasdaq Nordic: Helsinki [XHEL]
Nasdaq Nordic: Stockholm [XSTO]
SIX Swiss Exchange [XSWX]
Vienna Stock Exchange [XWBO]
Xetra [XETR]
Our engineers are working to verify the resolution and backfill the impacted dates as soon as possible. We will provide regular updates on the progress through the BMLL Status Page.
We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.
Yours sincerely, BMLL Support Team
Posted Aug 20, 2026 - 21:48 UTC
Identified
We have identified an issue resulting in an incomplete metrics data for the following exchanges and their associated Market Identifier Codes (MICs):
BME [XMAD]
Borsa Italiana [XMIL]
Euronext: Amsterdam [XAMS]
Euronext: Brussels [XBRU]
Euronext: Dublin [XDUB]
Euronext: Lisbon [XLIS]
Euronext: Oslo [XOSL]
Euronext: Paris [XPAR]
London Stock Exchange [XLON]
Nasdaq Nordic: Copenhagen [XCSE]
Nasdaq Nordic: Helsinki [XHEL]
Nasdaq Nordic: Stockholm [XSTO]
SIX Swiss Exchange [XSWX]
Vienna Stock Exchange [XWBO]
Xetra [XETR]
This caused metric calculation errors for a small subset of identities and metrics since 2026-08-12.
Market data is not impacted.
Our engineers are working to resolve the issue as soon as possible. We will provide regular updates on the progress through the BMLL Status Page.
We understand the importance of prompt data delivery for your operations and apologise for any inconvenience. For further questions and support, please contact the BMLL support team at support@bmlltech.com.
Yours sincerely, BMLL Support Team
Posted Aug 20, 2026 - 06:45 UTC
This incident affects: Data - Equities & ETFs - EMEA (BME [XMAD], Borsa Italiana [XMIL], Euronext: Amsterdam [XAMS], Euronext: Brussels [XBRU], Euronext: Dublin [XDUB], Euronext: Lisbon [XLIS], Euronext: Oslo [XOSL], Euronext: Paris [XPAR], London Stock Exchange [XLON], Nasdaq Nordic: Copenhagen [XCSE], Nasdaq Nordic: Helsinki [XHEL], Nasdaq Nordic: Stockholm [XSTO], SIX Swiss Exchange [XSWX], Vienna Stock Exchange [XWBO], Xetra [XETR]).